Author Topic: Problem with Mpgrad  (Read 20312 times)


  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Problem with Mpgrad
« on: February 08, 2007, 01:37:20 PM »
Hello All,

I am trying to run MP2 calculations in cc-pVTZ basis set for maleimide and athracene. I do it using these commands: first - dscf, second - rimp2, third - mp2prep, fourth - mpgrad, fifth - jobex -level -mp2 -ri -statpt -c 100. For maleimide everything is ok, but when I run all that same for anthracene, after mpgrad I have got in mpgrad.out this warning:

            PASS :   1
  too many records allocated for gamma#2 file !
  increase parameter ndirec to at least       761540

 MODTRACE: no modules on stack

 fatal error in mcore.
 mpgrad ended abnormally

I tried to find ndirec parameter in all files, but I did not found. I also tried to change mcore parameter, but without any results as well. So, I have no clue what to do with this problem...

Some technical informations: version of the program - Turbomole-5.7, architecture on which Turbomole was executed - Dual AMD Opteron 2600MHz, 16GB RAM, 2 x GigeE, 2 x 250GB disks.

Thank you very much in advance for your help,


  • Global Moderator
  • Hero Member
  • *****
  • Posts: 515
  • Karma: +0/-0
Re: Problem with Mpgrad
« Reply #1 on: February 12, 2007, 03:45:56 PM »

I guess that you want to do just an MP2 geometry optimization, right?

mpgrad and rimp2 are both doing MP2 calculations, the first one conventional, the second one with RI.
Since you are starting a RI-MP2 geometry optimization, there is no need to run mpgrad at all. Also the dscf and the rimp2 step are not necessary.

Just try:

1. run define
2. run rimp2prep
3. run 'jobex -ri -level mp2 -statpt -c 100'

Now to the problem with mpgrad:

mpgrad needs the correct size of the scratch file before starting the MP2 calculation. This is done by the script mp2prep automatically. In your case, either mp2prep has not been called, or it did not run as it should.

To get rid of the error, please do:

1. call 'stati mpgrad' at the command line
2. run mpgrad > mpgrad.stat

the first command just adds the keyword '$statistics mpgrad' to the control file. That forces mpgrad not to do the MP2 calculation, but to determine the sizes of the scratch files for the given number of loops ($traloop - you can set this to a higher number if the file sizes get too large, and redo the first two steps as given above.).

After that, please take a short look into your control file to check the sizes of the file gamma#2. The number is given in MB, and if this exceeds your disk space, you have to increase $traloop and redo the statistics as given above (to get the exact total disk space needed during the run, you have to look at the output of the mpgrad, mpgrad.stat in the example).

If the file sizes are o.k., just run mpgrad, or 'jobex -level mp2'.




  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Problem with Mpgrad
« Reply #2 on: February 12, 2007, 09:28:35 PM »
Dear Uwe,

first of all - thanks a lot for your very helpful reply  :)

You are right; I want to do geometry optimization for the maleimide and anhracene molecules on the MP2 level.

I thought that steps from 1st to 4th are necessary to good run of 'jobex' - so thank you for the explanation. When I have done RI-MP2 calculations like you suggested, everything was ok. I have got only one technical comment - the 'cbas' (auxiliary basis set) should not be set up in 'define', because it result in error during 'rimp2prep'. 'Rimp2prep' contain in itself a module which adds automatically auxiliary basis (same like basis set).

In connection with 'mpgrad', sorry to say, but I still have same problem... I have tried to use 'stati mpgrad' and after read in 'mpgrad.stat', but instead of statistics I obtained error exactly like in my first post. Interesting, when I did this for maleimide I obtained this:

           PASS :   1
 expected disk space for halftransformed integrals : 1855 Mbytes
 *   (halfint)
 expected disk space for exchange type integrals   :  279 Mbytes
 *   (moint#k)
 expected disk space for T2 amplitudes (MO basis)  :  445 Mbytes
 * o (gamma#1)
 expected disk space for AO two particle density   : 1668 Mbytes
  o (gamma#2)
 expected disk space for 1-external integrals      :   15 Mbytes
 *   (moint#1)
 expected total disk space for this pass : 2469 Mbytes
 (the files "*" and the files "o" are needed at the same time)
resulting maximum disk storage requirement          :      2469 Mbyte
 mpgrad statistics run ended normally

Maybe have you got any further suggestions - in case, when in the future I will need/have to use 'mpgrad'?

With best greetings,


  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 262
  • Karma: +0/-0
    • Hattig's Group at the RUB
Re: Problem with Mpgrad
« Reply #3 on: February 13, 2007, 11:37:07 AM »
Dear Uwe, dear Tomasz and all others who are interested in MP2 geometry optimization!

1) Problems with mp2prep/mpgrad for large cases: ???
      -   mpgrad has for a long time not been updated, the code is quite a bit outdated...,
          particulary, it can not deal with huge disc space and file sizes available today!
          As soon as one of the file sizes/pointers gets close to 16GB mpgrad gets
          integer overflows aborts (with messages which indicate completly different problems.)
      -   mp2prep invokes mpgrad for a stastics run and often does not detect or handle properly
           such problems of mpgrad
      Here is my way to avoid this problem: 8)
           - specify for mp2prep on the command line allways a maximum amount of disc space
             of at most 15000 Mb (using the -p option)
           -  check, if the file sizes written by mp2prep into the control file are all positive and smaller
              then 15000 Mb, if not, invoke again mp2prep, but let it start the statistic run(s) with an
              increased number of loops (using the -l option)
       Well, it's not an optimal work around, but mp2grad is today almost only used as benchmark
       for checking the quality of RI-MP2...

2) How to run efficiently RI-MP2 calculations: ::)
           a) the recommended way to set up the control file for RI-MP2 calculations is through the
                mp2 submenu of define! rimp2prep is no longer needed. All options for RI-MP2
                calculations which can be set with rimp2prep can also be set in define.
           b) the RI-MP2 code in the ricc2 program is in almost any case more efficient than the
               (older) code in the rimp2 program. The input is only slidely different and can also
               prepared with the define program. (see Chem. Phys. Lett. 358, 350-353 (2002) at

All the best,
« Last Edit: February 13, 2007, 01:14:51 PM by christof.haettig »


  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Problem with Mpgrad
« Reply #4 on: February 13, 2007, 10:22:17 PM »
Dear Christof,

thanks for the further explanations and suggestions, now all is clear and works properly  :D

My comments and hints:

ad 1) your way to avoid this problem is good  8) Moreover, now I understand why 'mpgrad' is only used as benchmark...
ad 2) ...because I have done some comparison between 'mpgrad' and 'rimp2' in 'ricc2' program (a citation from the manual: "All what is needed for a RI-MP2 gradient calculations with the RICC2 program is:

   geoopt model=mp2"

on the page 140) for the computer time consuming - the 'mpgrad' is still running...  ;)

Once again – thanks a lot for all help!

Ps: sorry for making mess in forum - by putting the question about "Mpgrad" in "Ridft" topic - but till today there was no topic "Mpgrad and Rimp2"  :)

Anne S.

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Problem with Mpgrad
« Reply #5 on: September 28, 2010, 04:13:43 PM »
Hi All!

I have also a problem with mpgrad. After a MP2 calculation I want to do an singel point corelation. First I had make dft. Then I input mp2prep with m 900 p 15000 and l up to 35. But always I get the massage:

Statistics run of mpgrad (traloop=35)...
ERROR! grep of disk storage requirement in /tmp/mp2prep.23901.mpout failed
The last 20 lines of this file:
    mo occupation :
   irrep   mo's   occupied
    a     1449       72

 number of basis functions   :          1449
 number of occupied orbitals :            72

 reading orbital data $scfmo  from file mos .

 orbital characterization : scfdump=30

 self consistent orbitals required

 MODTRACE: no modules on stack

  <mpgrad>: faulty scf orbitals
 mpgrad ended abnormally

But all looks like the same in smaler calculation. At these I have no problem. So do you have an Idear, what I could do?

Thank you very much in advance for your help.


  • Developers
  • Sr. Member
  • *
  • Posts: 247
  • Karma: +0/-0
Re: Problem with Mpgrad
« Reply #6 on: September 28, 2010, 09:09:58 PM »
Hello Anne,

this means, your Hartree-Fock calculation is not converged. In the output of dscf you will find the messages:
' convergence criteria cannot be satisfied within  30 iterations !' and
' ATTENTION : $energy will not be updated since
 this calculation did not converge (sob)'
Please try to converge the mos first.