Author Topic: configuring TmoleX for queue that runs on local system  (Read 138 times)

KrisR

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
configuring TmoleX for queue that runs on local system
« on: April 22, 2021, 03:01:44 PM »
Usually I use TmoleX on my windows PC and submit the jobs into the queue on our cluster.
However I can't get the parameters of TmoleX on head-node right, i.e. if TmoleX is started directly on a head-node were the qsub command can be started.

Option [Run (local)] works but I don't want to compute on head-end node of our cluster.
I couldn't find any option for running queue on local system so I assumed that I need to use [Run (network)].
I configured all parameters as on my windows PC with an exception that I gave no password (on cluster  ssh-keys do not have passphrase).

When I try [Test remote system] dialog appears:
"Currently trying to copy check_remote-file to machine
Lost connection".

After confirming this dialog another one pops up:
"Error while copying back
Please copy files form machine user@head-node-ip
in directory /home/user/TmoleXProject/checkInstallDirectory manually"

I have no clue where this file "checkInstallDirectory" is located, so I can't copy it.
TmoleX-script was started from /home/user/TmoleXProject and there is no such file.

Obviously ssh to head-node from head-node itself works (without passphrase).
I tried submission dialog with pointing to ssh-key (-i option) and without -- no difference.


Does anyone have any suggestion on how to configure it?

best regards, Kris

uwe

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 486
  • Karma: +0/-0
Re: configuring TmoleX for queue that runs on local system
« Reply #1 on: April 22, 2021, 03:25:30 PM »
Hi,

it is quite unusual that the server of a cluster is at the same time a desktop machine. If you usually submit the job from your Windows machine to the queueing system, and as I guess that your Windows machine is not the head node of the cluster, why do you want to submit jobs from a remote machine to a remote machine in addition or as an alternative? OK, sorry, questions about 'why' are more out of curiosity and not helpful as answers...

If ssh to the same machine works, the Run(network) option should work too. What comes to my mind when thinking about possible problems is the fact that the local directory and the remote directory must not be the same. Please try to set as working directory on the remote machine a different path than the one of your project.

Did you enable 'Expert  settings' in the remote systems dialog and set a check at 'no password'?

Will you ALWAYS be submitting jobs to the local queuing system and not use another remote machine or cluster from this TmoleX client on that machine? If yes, you could try to fool TmoleX. Replace the ssh and scp binaries that you will find in the local TmoleX installation by scripts which simply do nothing but execute the commands that are given as options. It will be a bit of a puzzle to find out how to do that exactly (e.g. Tmolex will be called 'ssh user@machine mkdir /home/user/TmoleXProject/job_SP_1', so your ssh script has to ignore the first option and execute the rest locally. Same for scp which has to be replaced by a simple 'cp' but ignores the machine and the user name.).

Regards,
Uwe

KrisR

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: configuring TmoleX for queue that runs on local system
« Reply #2 on: April 22, 2021, 06:22:32 PM »
Hi Uwe,
I'll try to answer questions in order.

1st of all: "why-question".
Well, we are here mostly preparative institute and ph.d.-students using QM to compare or to confirm some spectroscopic data. We have a few post-docs that are on higher level but majority of users misuse QM ;-)
Most students use gaussian/gaussview which they have installed both in cluster and on their PCs. They are used to open their results "as it goes". If they are in some windows directory they start windows versions if they are on cluster and they were checking log-files they starting gaussview on cluster.
I really would love to make them more aware of capabilities of turbomole and tmolex plays there huge role. But they are chemists working in lab not in silico. They need to see results.
For that reason I've not only installed turbomole on our cluster but also tmolex.
In hands-on seminars I'm explaining how to configure TmoleX for remote queue but there is always danger that they will start it on cluster. If a few of them will start local computations on head-node we will be not able to log-in.
For that reason I'd like to explain them how to configure TmoleX to work on cluster.

I tried the option with different directory and it did not worked. I didn't have much hope as the test connection did not worked but I tried. I couldn't see anything it TmoleX and also qstat didn't show a submitted job.

With fooling TmoleX -- I'll try it tomorrow and I will let you know.

Thanks for response, Kris

KrisR

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: configuring TmoleX for queue that runs on local system
« Reply #3 on: April 23, 2021, 11:07:41 AM »
About fooling...
I found this directory `/opt/TmoleX2021/extapps/putty`and there were two programs `pscp`and `pssh`.
I tried to use `pssh` to connect to another server. It writes what user-name will be used but no connection is built.
Also `pscp` does not work -- the only message when I tried to copy a file is "Lost connection".

I replaced both these binaries with links to /usr/bin/ssh and /usr/bin/scp and then I've seen that the job was submitted to queue and eventually calculation has succeeded.
I have used the same directory and it seems that TmoleX has no problem with that. It just created additional temporary directory that was eventually removed.
So it seems at first glance that something is wrong with compiled versions of plink and pscp on linux.

I'm happy - it works :-D
« Last Edit: April 23, 2021, 02:08:40 PM by KrisR »